Discussion:
startup failed
(too old to reply)
BÖSCH Christian
2015-11-11 07:54:46 UTC
Permalink
Hi,

I set up an openldap server with all desired configs (cn=config, mmr, etc etc) as node 1.
Then I start it up, which is quite slow (I think it waits on node 2 which is not available yet).
Then I add an empty base tree:

dn: dc=example,dc=net
objectClass: dcObject
objectClass: organization
o: ORG1
o: ORG2
dc: example

dn: cn=admin,dc=example,dc=net
objectClass: organizationalRole
cn: LDAP Admin
cn: admin

dn: o=org1,dc=example,dc=net
o: ORG1
objectClass: organization
objectClass: top

dn: o=org2,dc=example,dc=net
o: ORG2
objectClass: organization
objectClass: top

After that restarting slapd always fails. That’s in debug log:

Nov 11 08:35:00 openldap1 slapd[27812]: slapd startup: initiated.
Nov 11 08:35:00 openldap1 slapd[27812]: backend_startup_one: starting "cn=config"
Nov 11 08:35:00 openldap1 slapd[27812]: config_back_db_open
Nov 11 08:35:00 openldap1 slapd[27812]: backend_startup_one: starting "dc=example,dc=net"
Nov 11 08:35:00 openldap1 slapd[27812]: mdb_db_open: database "dc=example,dc=net": dbenv_open(/var/db/openldap-data).
Nov 11 08:35:00 openldap1 slapd[27812]: => mdb_search
Nov 11 08:35:00 openldap1 slapd[27812]: mdb_dn2entry("dc=example,dc=net")
Nov 11 08:35:00 openldap1 slapd[27812]: => mdb_dn2id("dc=example,dc=net")
Nov 11 08:35:00 openldap1 slapd[27812]: <= mdb_dn2id: got id=0x1
Nov 11 08:35:00 openldap1 slapd[27812]: => mdb_entry_decode:
Nov 11 08:35:00 openldap1 slapd[27812]: <= mdb_entry_decode
Nov 11 08:35:00 openldap1 slapd[27812]: search_candidates: base="dc=example,dc=net" (0x00000001) scope=2
Nov 11 08:35:00 openldap1 slapd[27812]: => mdb_equality_candidates (objectClass)
Nov 11 08:35:00 openldap1 slapd[27812]: => key_read
Nov 11 08:35:00 openldap1 slapd[27812]: <= mdb_index_read: failed (-30798)
Nov 11 08:35:00 openldap1 slapd[27812]: <= mdb_equality_candidates: id=0, first=0, last=0
Nov 11 08:35:00 openldap1 slapd[27812]: => mdb_equality_candidates (objectClass)
Nov 11 08:35:00 openldap1 slapd[27812]: => key_read
Nov 11 08:35:00 openldap1 slapd[27812]: <= mdb_index_read: failed (-30798)
Nov 11 08:35:00 openldap1 slapd[27812]: <= mdb_equality_candidates: id=0, first=0, last=0
Nov 11 08:35:00 openldap1 slapd[27812]: mdb_search_candidates: id=0 first=0 last=0
Nov 11 08:35:00 openldap1 slapd[27812]: mdb_search: no candidates
Nov 11 08:35:00 openldap1 slapd[27812]: send_ldap_result: conn=-1 op=0 p=0

Does anybody see the problem?
King regards,
Chris

Loading...