Discussion:
*** Error in `/usr/sbin/slapd': double free or corruption (top): 0x00007f2f9503a610 ***
(too old to reply)
Andrei Valoshyn
2015-11-04 15:40:58 UTC
Permalink
Raw Message
Hello!
I have ubuntu 14.04 and openldap-2.4.31 server which I had installed via
apt-get.
I tried configure it via slapd.conf configuration file.
After all configurations steps and success config test I faced with:
/
***@v122:~# /etc/init.d/slapd start//
// * Starting OpenLDAP slapd //
// *** Error in `/usr/sbin/slapd': double free or corruption (top):
0x00007f2f9503a610 ***//
//Aborted (core dumped)/

I can't find any reported bug about this issue. Please help!
--
With Best Wishes
Andrei Valoshyn
Exadel Inc.
System Administrator
***@exadel.com
--
CONFIDENTIALITY NOTICE: This email and files attached to it are
confidential. If you are not the intended recipient you are hereby notified
that using, copying, distributing or taking any action in reliance on the
contents of this information is strictly prohibited. If you have received
this email in error please notify the sender and delete this email.
Quanah Gibson-Mount
2015-11-04 16:22:05 UTC
Permalink
Raw Message
Content preview: --On Wednesday, November 04, 2015 6:40 PM +0300 Andrei Valoshyn
<***@exadel.com> wrote: > Hello! > I have ubuntu 14.04 and openldap-2.4.31
server which I had installed via > apt-get. Use a current release. 2.4.31
is 3.5 years old. [...]

Content analysis details: (-4.3 points, 5.0 required)

pts rule name description
---- ---------------------- --------------------------------------------------
-2.3 RCVD_IN_DNSWL_MED RBL: Sender listed at http://www.dnswl.org/, medium
trust
[162.209.122.184 listed in list.dnswl.org]
0.0 URIBL_BLOCKED ADMINISTRATOR NOTICE: The query to URIBL was blocked.
See
http://wiki.apache.org/spamassassin/DnsBlocklists#dnsbl-block
for more information.
[URIs: zimbra.com]
-0.0 SPF_PASS SPF: sender matches SPF record
0.0 RP_MATCHES_RCVD Envelope sender domain matches handover relay domain
-1.9 BAYES_00 BODY: Bayes spam probability is 0 to 1%
[score: 0.0000]
-0.1 DKIM_VALID_AU Message has a valid DKIM or DK signature from author's
domain
0.1 DKIM_SIGNED Message has a DKIM or DK signature, not necessarily valid
-0.1 DKIM_VALID Message has at least one valid DKIM or DK signature

--On Wednesday, November 04, 2015 6:40 PM +0300 Andrei Valoshyn
Post by Andrei Valoshyn
Hello!
I have ubuntu 14.04 and openldap-2.4.31 server which I had installed via
apt-get.
Use a current release. 2.4.31 is 3.5 years old.

---Quanah

--

Quanah Gibson-Mount
Platform Architect
Zimbra, Inc.
--------------------
Zimbra :: the leader in open source messaging and collaboration
Ryan Tandy
2015-11-04 16:29:52 UTC
Permalink
Raw Message
Content preview: On Wed, Nov 04, 2015 at 06:40:58PM +0300, Andrei Valoshyn
wrote: >I have ubuntu 14.04 and openldap-2.4.31 server which I had installed
via apt-get. >I tried configure it via slapd.conf configuration file. >After
all configurations steps and success config test I faced with: >/ > ***@v122:~#
/etc/init.d/slapd start// >// * Starting OpenLDAP slapd // >// *** Error
in `/usr/sbin/slapd': double free or corruption (top): >0x00007f2f9503a610
***// >//Aborted (core dumped)/ [...]

Content analysis details: (-1.2 points, 5.0 required)

pts rule name description
---- ---------------------- --------------------------------------------------
-0.7 RCVD_IN_DNSWL_LOW RBL: Sender listed at http://www.dnswl.org/, low
trust
[209.85.220.49 listed in list.dnswl.org]
0.0 URIBL_BLOCKED ADMINISTRATOR NOTICE: The query to URIBL was blocked.
See
http://wiki.apache.org/spamassassin/DnsBlocklists#dnsbl-block
for more information.
[URIs: nardis.ca]
-0.0 SPF_PASS SPF: sender matches SPF record
-1.9 BAYES_00 BODY: Bayes spam probability is 0 to 1%
[score: 0.0000]
-0.1 DKIM_VALID_AU Message has a valid DKIM or DK signature from author's
domain
0.1 DKIM_SIGNED Message has a DKIM or DK signature, not necessarily valid
-0.1 DKIM_VALID Message has at least one valid DKIM or DK signature
1.5 FAKE_REPLY_C FAKE_REPLY_C
I have ubuntu 14.04 and openldap-2.4.31 server which I had installed
via apt-get.
I tried configure it via slapd.conf configuration file.
/
// * Starting OpenLDAP slapd //
0x00007f2f9503a610 ***//
//Aborted (core dumped)/
Did you configure a TLSCipherSuite? If you did so, and it's not a
correct GnuTLS priority string, then you may be encountering a known bug
that is fixed in later releases:

https://bugs.launchpad.net/bugs/1103353
--On Wednesday, November 04, 2015 6:40 PM +0300 Andrei Valoshyn
Use a current release. 2.4.31 is 3.5 years old.
If you want to try a newer release, I maintain a PPA of backports from
later Ubuntu releases to the LTS:

https://launchpad.net/~rtandy/+archive/ubuntu/openldap-backports

It's not officially supported, of course, but it avoids some of the
known bugs in 2.4.31.

Loading...